summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZheng junjie <873216071@qq.com>2021-06-11 21:11:54 +0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-06-13 19:14:12 +0200
commit34c474ecf44434a3f2857f4646d995b4f7f9014a (patch)
tree6a9a7e315b22f2d05327ea1ca38440649c09329c /gnu
parent94bb3f65b6cd3748f5e5e2821886e661a2645f7b (diff)
gnu: Add rust-serde-path-to-error-0.1.
* gnu/packages/crates-io.scm (rust-serde-path-to-error-0.1): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7aed89fe87..ee3c578ca6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -39813,6 +39813,35 @@ data. This crate provides a wrapper that works with any existing Serde
"Macros to auto-generate implementations for the serde framework.")
(license (list license:expat license:asl2.0))))
+(define-public rust-serde-path-to-error-0.1
+ (package
+ (name "rust-serde-path-to-error")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "serde-path-to-error" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0n5ilbsxvi174m2fd506ivd43kws0yh523li1xz0zqh60ngi1xj2"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-serde" ,rust-serde-1))
+ #:cargo-development-inputs
+ (("rust-serde-derive" ,rust-serde-derive-1)
+ ("rust-serde-json" ,rust-serde-json-1))))
+ (home-page
+ "https://github.com/dtolnay/path-to-error")
+ (synopsis
+ "Path to the element that failed to deserialize")
+ (description
+ "This package provides a path to the element that failed to deserialize.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-serde-qs-0.7
(package
(name "rust-serde-qs")