summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-20 11:58:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-20 12:19:55 +0100
commit35f9c6628fd52adca03d08e503d65fa68c573a8e (patch)
tree0b08f4fe5179b87e2fe41dc3db6a79ada1cafb1e /gnu
parent7627bad6a7869b3f12b6659c326924f35a6fb28f (diff)
gnu: Add adapterremoval.
* gnu/packages/bioinformatics.scm (adapterremoval): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index edfc651026..840ddfad17 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14602,3 +14602,40 @@ tools which build on STAR, Arriba does not require to reduce the
;; All code is under the Expat license with the exception of
;; "draw_fusions.R", which is under GPLv3.
(license (list license:expat license:gpl3))))
+
+(define-public adapterremoval
+ (package
+ (name "adapterremoval")
+ (version "2.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MikkelSchubert/adapterremoval.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1nf3ki5pfzalhrx2fr1y6pfqfi133yj2m7q4fj9irf5fb94bapwr"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags (list "COLOR_BUILD=no"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (inputs
+ `(("zlib" ,zlib)))
+ (home-page "https://adapterremoval.readthedocs.io/")
+ (synopsis "Rapid sequence adapter trimming, identification, and read merging")
+ (description
+ "This program searches for and removes remnant adapter sequences from
+@dfn{High-Throughput Sequencing} (HTS) data and (optionally) trims low quality
+bases from the 3' end of reads following adapter removal. AdapterRemoval can
+analyze both single end and paired end data, and can be used to merge
+overlapping paired-ended reads into (longer) consensus sequences.
+Additionally, the AdapterRemoval may be used to recover a consensus adapter
+sequence for paired-ended data, for which this information is not available.")
+ (license license:gpl3+)))