summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 00:57:06 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:20 +0200
commit38563d9140bdd35215d36cffae890d7db891d597 (patch)
tree686c97f5c3d39fb731c227cd57d37bdf0ed5a690 /gnu
parent128c4c40e48db02e313d782d7aeb705418bde035 (diff)
gnu: ghc-adjunctions: Update to 4.4.
* gnu/packages/haskell.scm (ghc-adjunctions): Update to 4.4. [inputs] Add ghc-transformers-compat. [native-inputs]: Add ghc-generic-deriving, ghc-hspec, and hspec-discover.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index da48a64b0a..394c541693 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5121,7 +5121,7 @@ definition of @code{Monad}.")
(define-public ghc-adjunctions
(package
(name "ghc-adjunctions")
- (version "4.3")
+ (version "4.4")
(source
(origin
(method url-fetch)
@@ -5131,7 +5131,7 @@ definition of @code{Monad}.")
".tar.gz"))
(sha256
(base32
- "1k1ykisf96i4g2zm47c45md7p42c4vsp9r73392pz1g8mx7s2j5r"))))
+ "1sbal7cbhm12crfnfhkk322jnzgx7lhw3jzq0p463bipagsjwz2h"))))
(build-system haskell-build-system)
(inputs
`(("ghc-profunctors" ,ghc-profunctors)
@@ -5142,7 +5142,12 @@ definition of @code{Monad}.")
("ghc-tagged" ,ghc-tagged)
("ghc-semigroupoids" ,ghc-semigroupoids)
("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)
("ghc-void" ,ghc-void)))
+ (native-inputs
+ `(("ghc-generic-deriving" ,ghc-generic-deriving)
+ ("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)))
(home-page "https://github.com/ekmett/adjunctions/")
(synopsis "Adjunctions and representable functors")
(description "This library provides adjunctions and representable functors