summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-07 17:22:17 -0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-09-08 13:51:15 +0200
commita8095cd52ae3cc55fe584359fa4dab92b5c5e1b1 (patch)
tree70166ec385d955447de3263466767774a87618f9 /gnu
parentcce5e1260a23d4f9284f44c4cc6ede80b9cbfae0 (diff)
gnu: Add emacs-gdscript-mode.
* gnu/packages/emacs-xyz.scm (emacs-gdscript-mode): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b478c1743f..b346562959 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3209,6 +3209,29 @@ project.
This package also includes relevant snippets for yasnippet.")
(license license:expat))))
+(define-public emacs-gdscript-mode
+ (package
+ (name "emacs-gdscript-mode")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/godotengine/emacs-gdscript-mode")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02by4bvdayldbjlz6jkp36m5rgcy2h5bwhqx2cj7wma6xf6cw3lf"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/godotengine/emacs-gdscript-mode")
+ (synopsis "GDScript support and syntax highlighting in Emacs")
+ (description
+ "This package adds support for the GDScript programming language from the
+Godot game engine in Emacs. It features all the essentials, e.g., syntax
+highlighting, code folding, indentation, automatic pairing, auto-completion,
+and code formatting.")
+ (license license:gpl3+)))
+
(define-public emacs-el-mock
(package
(name "emacs-el-mock")