summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 23:22:32 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:20 +0200
commitb587518960e560309ec69d480eef7fc6aa8abcd2 (patch)
treee26d60f766c9b5d3612b0f6218eb0f570e4c3b11 /gnu
parent751a8c0b43268aa5b33bae9fe5615c9dcf5abcfb (diff)
gnu: ghc-fsnotify: Update to 0.3.0.1.
* gnu/packages/haskell.scm (ghc-fsnotify): Update to 0.3.0.1. [inputs]: Remove ghc-temporary-rc; add ghc-temporary, ghc-random, and ghc-shelly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 734dc2c2ca..d1e7145d0b 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8158,7 +8158,7 @@ accessed or modified.")
(define-public ghc-fsnotify
(package
(name "ghc-fsnotify")
- (version "0.2.1")
+ (version "0.3.0.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -8166,7 +8166,7 @@ accessed or modified.")
"fsnotify-" version ".tar.gz"))
(sha256
(base32
- "0asl313a52qx2w6dw25g845683xsl840bwjh118nkwi5v1xipkzb"))))
+ "19bdbz9wb9jvln6yg6qm0hz0w84bypvkxf0wjhgrgd52f9gidlny"))))
(build-system haskell-build-system)
(inputs
`(("ghc-text" ,ghc-text)
@@ -8175,7 +8175,9 @@ accessed or modified.")
("ghc-hinotify" ,ghc-hinotify)
("ghc-tasty" ,ghc-tasty)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
- ("ghc-temporary-rc" ,ghc-temporary-rc)))
+ ("ghc-random" ,ghc-random)
+ ("ghc-shelly" ,ghc-shelly)
+ ("ghc-temporary" ,ghc-temporary)))
(home-page "https://github.com/haskell-fswatch/hfsnotify")
(synopsis "Cross platform library for file change notification.")
(description "Cross platform library for file creation, modification, and