summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-29 01:00:52 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:20 +0200
commitc237721ea5491dfd115151cad06dfb9faee71d36 (patch)
treeae6a8bcde24b82cfca3cb3fcac06667012a20329 /gnu
parent6369346e5427ea506be15d1b3fa2fed4ac27659d (diff)
gnu: ghc-vector-builder: Update to 0.3.6.
* gnu/packages/haskell.scm (ghc-vector-builder): Update to 0.3.6. [native-inputs]: Add ghc-attoparsec and ghc-rerebase; remove ghc-rebase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 3423164dc1..2272fd4d51 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9364,7 +9364,7 @@ the project's home page}.")
(define-public ghc-vector-builder
(package
(name "ghc-vector-builder")
- (version "0.3.1")
+ (version "0.3.6")
(source
(origin
(method url-fetch)
@@ -9373,17 +9373,18 @@ the project's home page}.")
"vector-builder-" version ".tar.gz"))
(sha256
(base32
- "1l6sfgd2s107zkp1qd1w6jdjcbznp31769qf99pxar087f697wvp"))))
+ "06d2pa1fb3ydrl7l6rjazqyxv5i73v65x2f5fp0ypjxfbm6jsmn8"))))
(build-system haskell-build-system)
(inputs `(("ghc-vector" ,ghc-vector)
("ghc-semigroups" ,ghc-semigroups)
("ghc-base-prelude" ,ghc-base-prelude)))
- (native-inputs `(("ghc-tasty" ,ghc-tasty)
+ (native-inputs `(("ghc-attoparsec" ,ghc-attoparsec)
+ ("ghc-tasty" ,ghc-tasty)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
("ghc-hunit" ,ghc-hunit)
("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
- ("ghc-rebase" ,ghc-rebase)))
+ ("ghc-rerebase" ,ghc-rerebase)))
(home-page "https://github.com/nikita-volkov/vector-builder")
(synopsis "Vector builder for Haskell")
(description "This Haskell package provides an API for constructing vectors.