summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-22 09:47:49 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:21 +0200
commitc4a68deaad5e32894f881035613c2cdaedf9f61a (patch)
treeda6637e5e17b20747f7da5d66b1f8a51b1d8a806 /gnu
parent478365e36a59355001d46ee136dc550fccfb9c16 (diff)
gnu: Add ghc-echo.
* gnu/packages/haskell.scm (ghc-echo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 85692c4689..079d8561ce 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1852,6 +1852,32 @@ Writer monad), where list append quickly becomes too expensive.")
versions of GHC (i.e., < 6.10).")
(license license:bsd-3)))
+(define-public ghc-echo
+ (package
+ (name "ghc-echo")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/echo/echo-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1vw5ykpwhr39wc0hhcgq3r8dh59zq6ib4zxbz1qd2wl21wqhfkvh"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("1" "0br8wfiybcw5hand4imiw0i5hacdmrax1dv8g95f35gazffbx42l")))
+ (home-page "https://github.com/RyanGlScott/echo")
+ (synopsis "Echo terminal input portably")
+ (description "The @code{base} library exposes the @code{hGetEcho} and
+@code{hSetEcho} functions for querying and setting echo status, but
+unfortunately, neither function works with MinTTY consoles on Windows.
+This library provides an alternative interface which works with both
+MinTTY and other consoles.")
+ (license license:bsd-3)))
+
(define-public cabal-install
(package
(name "cabal-install")