summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:40:26 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitf221841c69a168ec677b29f5c4cebda863c0fda8 (patch)
treef1d04e856f24b0e93862eae57da03cfe9667c820 /gnu
parentfad564ec035a3e0b99c3e28704070fb751480852 (diff)
gnu: Add ghc-profunctors.
* gnu/packages/haskell.scm (ghc-profunctors): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index eeff0d8c74..a499a6ad69 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1375,6 +1375,31 @@ functionality. A few functions are available in later versions of GHC, but
this package makes them available back to GHC 7.2.")
(license bsd-3)))
+(define-public ghc-profunctors
+ (package
+ (name "ghc-profunctors")
+ (version "5.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/profunctors/profunctors-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0lw2ipacpnp9yqmi8zsp01pzpn5hwj8af3y0f3079mddrmw48gw7"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-distributive" ,ghc-distributive)))
+ (inputs
+ `(("ghc-comonad" ,ghc-comonad)
+ ("ghc-tagged" ,ghc-tagged)))
+ (home-page "http://github.com/ekmett/profunctors/")
+ (synopsis "Profunctors for Haskell")
+ (description "This library provides profunctors for Haskell.")
+ (license bsd-3)))
+
(define-public ghc-appar
(package
(name "ghc-appar")