summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-01 00:08:45 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-01 00:08:45 +0200
commitf3fb92e5552ebc216af4b688ea6a07f3404c748f (patch)
tree2d0c27b23a6da66e6901576b880ae92e5d31ee5c /gnu
parenta459697e0e51c82ff5e0313972c20f74b96058ae (diff)
gnu: Add at-spi2-core.
* gnu/packages/gtk.scm (at-spi2-core): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index f75d0b8ecc..ed2ba60448 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -184,6 +184,35 @@ in the GNOME project.")
(license license:lgpl2.0+)
(home-page "https://developer.gnome.org/gdk-pixbuf/")))
+(define-public at-spi2-core
+ (package
+ (name "at-spi2-core")
+ (version "2.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (string-take version 4) "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1ns44yibdgcwzwri7sr075hfs5rh5lgxkh71247a0822az3mahcn"))))
+ (build-system gnu-build-system)
+ (inputs `(("dbus" ,dbus)
+ ("glib" ,glib)
+ ("intltool" ,intltool)
+ ("libxi" ,libxi)
+ ("libxtst" ,libxtst)
+ ("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f)) ; FIXME: dbind/dbtest fails; one should disable tests in
+ ; a more fine-grained way.
+ (synopsis "Assistive Technology Service Provider Interface, core components")
+ (description
+ "The Assistive Technology Service Provider Interface, core components,
+is part of the GNOME accessibility project.")
+ (license license:lgpl2.0+)
+ (home-page "https://projects.gnome.org/accessibility/")))
+
(define-public gtk+
(package
(name "gtk+")