summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 15:34:48 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commitfa4f5024bcc42514de005d92b138ed7f2d25e5a8 (patch)
treecfaed7405d4052b8f4a11e3ad558af93c552d18f /gnu
parent10e614523f7af4e3b9ee45da01dcb11f2c827c18 (diff)
gnu: Add ghc-distributive.
* gnu/packages/haskell.scm (ghc-distributive): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d1edef698e..939d2e79c3 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1219,6 +1219,32 @@ Haskell.")
modifying, and extracting files from zip archives in Haskell.")
(license bsd-3)))
+(define-public ghc-distributive
+ (package
+ (name "ghc-distributive")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/distributive/distributive-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0s2ln9jv7bh4ri2y31178pvjl8x6nik5d0klx7j2b77yjlsgblc2"))))
+ (build-system haskell-build-system)
+ (arguments `(#:tests? #f)) ; FIXME: fails with "cannot satisfy -package
+ ; tagged-0.8.1". Suspected Cabal issue.
+ (propagated-inputs
+ `(("ghc-tagged" ,ghc-tagged)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (home-page "http://github.com/ekmett/distributive/")
+ (synopsis "Distributive functors for Haskell")
+ (description "This package provides distributive functors for Haskell.
+Dual to @code{Traversable}.")
+ (license bsd-3)))
+
(define-public ghc-cereal
(package
(name "ghc-cereal")