summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-02 16:09:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:17 +0200
commit57f265f1eaedd346cb68fe0fd80cb0566e54876f (patch)
tree74ec7eddc4d065bf982a6b9ecee2f732d3a12fdc /gnu
parent262df6c6071bbed95635a17df3cda44360992ab1 (diff)
gnu: python-dask: Do not reference pyarrow_hotfix.
* gnu/packages/python-xyz.scm (python-dask)[arguments]: Add 'patch-pyproject phase. Change-Id: Idd173b72b1467540c295224072f3740c7f42b0a8
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4128a5e0d5..c70e44270f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28109,6 +28109,11 @@ parentdir_prefix = dask-
;; This option is not supported by our version of pytest.
(substitute* "pyproject.toml"
(("--cov-config=pyproject.toml") ""))))
+ (add-after 'unpack 'patch-pyproject
+ (lambda _
+ ;; We use pyarrow > 14
+ (substitute* "pyproject.toml"
+ (("\"pyarrow_hotfix\",") ""))))
(add-before 'check 'pre-check
(lambda _ (chdir "/tmp"))))))
(propagated-inputs