summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-03 10:55:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:18 +0200
commitcb9ec4c5c59d5a9b6d8d999acc7c84d5eff5e3b9 (patch)
tree6043d02404b1e684e36977ab820096cee727b62e /gnu
parent0e246350336f68bc03f27b709cb6e765b160c8d2 (diff)
gnu: python-decoupler-py: Update to 1.6.0.
* gnu/packages/bioinformatics.scm (python-decoupler-py): Update to 1.6.0. [arguments]: Do not disable test_plot_volcano test. Change-Id: I44a31d30e8a03d2d1ffd86383c8bc6db79628def
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm119
1 files changed, 55 insertions, 64 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 78c71447d5..dff8ba4d87 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2026,71 +2026,62 @@ parsing of Variant Call Format (VCF) files.")
(license license:expat)))
(define-public python-decoupler-py
- ;; This latest commit fixes a bug in test_omnip.py.
- (let ((commit "459b235348ddd9135217a3722d9dd1caa9a14ace")
- (revision "1"))
- (package
- (name "python-decoupler-py")
- (version (git-version "1.5.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/saezlab/decoupler-py")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1c0xk006iilyffdaqar2d05qdhik22fbkny387zx0bndkgqifxhl"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- '(list "-k"
- ;; These tests require internet access
- (string-append "not test_get_resource"
- " and not test_show_resources"
- " and not test_get_dorothea"
- " and not test_get_progeny"
- " and not test_get_ksn_omnipath"
- ;; XXX module 'omnipath.interactions' has no
- ;; attribute 'CollecTRI'
- " and not test_get_collectri"
- ;; XXX This one fails because the "texts" list
- ;; is empty, so there are no texts to adjust.
- ;; It is not clear whether this a compatibility
- ;; problem with our adjusttext package.
- " and not test_plot_volcano"))
- #:phases
- '(modify-phases %standard-phases
- (add-before 'check 'set-home
- ;; Some tests require a home directory to be set.
- (lambda _ (setenv "HOME" "/tmp")))
- ;; Numba needs a writable dir to cache functions.
- (add-before 'build 'set-numba-cache-dir
- (lambda _ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
- (propagated-inputs (list python-adjusttext
- python-anndata
- python-ipython
- python-matplotlib
- python-nbsphinx
- python-numba
- python-numpy
- python-numpydoc
- python-omnipath
- python-scanpy
- python-scikit-learn
- python-scipy
- python-skranger
- python-tqdm
- python-typing-extensions))
- (native-inputs (list python-pytest))
- (home-page "https://github.com/saezlab/decoupler-py")
- (synopsis
- "Framework for modeling, analyzing and interpreting single-cell RNA-seq data")
- (description
- "This package provides different statistical methods to extract
+ (package
+ (name "python-decoupler-py")
+ (version "1.6.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/saezlab/decoupler-py")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1mqkp0i8k5hzhfnka4nc2f0phmrs0k404ynbl1lqfjzywx25y75h"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ '(list "-k"
+ ;; These tests require internet access
+ (string-append "not test_get_resource"
+ " and not test_show_resources"
+ " and not test_get_dorothea"
+ " and not test_get_progeny"
+ " and not test_get_ksn_omnipath"
+ ;; This attempts to download things for Omnipath
+ " and not test_get_collectri"))
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'check 'set-home
+ ;; Some tests require a home directory to be set.
+ (lambda _ (setenv "HOME" "/tmp")))
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs (list python-adjusttext
+ python-anndata
+ python-ipython
+ python-matplotlib
+ python-nbsphinx
+ python-numba
+ python-numpy
+ python-numpydoc
+ python-omnipath
+ python-scanpy
+ python-scikit-learn
+ python-scipy
+ python-skranger
+ python-tqdm
+ python-typing-extensions))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/saezlab/decoupler-py")
+ (synopsis
+ "Framework for modeling, analyzing and interpreting single-cell RNA-seq data")
+ (description
+ "This package provides different statistical methods to extract
biological activities from omics data within a unified framework.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public python-demuxem
(package