summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-27 15:51:58 +0100
committerMarius Bakke <marius@gnu.org>2022-11-27 21:19:50 +0100
commitef51ca870fdeb8689eee8771000dd13831c0de6d (patch)
treedf39b567a452a80b09ed54259167c37314ad5047 /gnu
parent1fb51bd5af7d673cb3c01c5e16d44380d84237fe (diff)
gnu: sooperlooper: Remove input labels.
* gnu/packages/music.scm (sooperlooper)[inputs]: Remove labels. [arguments]: Use SEARCH-INPUT-DIRECTORY instead of labels.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d88b7bd20e..22b8ca7d68 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3945,13 +3945,13 @@ with a number of bugfixes and changes to improve IT playback.")
(modify-phases %standard-phases
(add-after 'unpack 'add-sigc++-includes
(lambda* (#:key inputs #:allow-other-keys)
- (let ((sig (assoc-ref inputs "libsigc++"))
- (xml (assoc-ref inputs "libxml2"))
+ (let ((sig (search-input-directory inputs "include/sigc++-2.0"))
+ (xml (search-input-directory inputs "include/libxml2"))
(cwd (getcwd)))
(setenv "CPATH"
- (string-append sig "/include/sigc++-2.0:"
- sig "/lib/sigc++-2.0/include:"
- xml "/include/libxml2/:"
+ (string-append sig ":"
+ sig "../../lib/sigc++-2.0/include:"
+ xml ":"
cwd "/libs/pbd:"
cwd "/libs/midi++:"
(or (getenv "CPATH") ""))))
@@ -3978,16 +3978,16 @@ with a number of bugfixes and changes to improve IT playback.")
(("static char") "static const char"))
#t)))))
(inputs
- `(("jack" ,jack-1)
- ("alsa-lib" ,alsa-lib)
- ("wxwidgets" ,wxwidgets-gtk2)
- ("libsndfile" ,libsndfile)
- ("libsamplerate" ,libsamplerate)
- ("liblo" ,liblo)
- ("rubberband" ,rubberband)
- ("libxml2" ,libxml2)
- ("libsigc++" ,libsigc++-2)
- ("ncurses" ,ncurses)))
+ (list jack-1
+ alsa-lib
+ wxwidgets-gtk2
+ libsndfile
+ libsamplerate
+ liblo
+ rubberband
+ libxml2
+ libsigc++-2
+ ncurses))
(native-inputs
(list pkg-config))
(home-page "https://sonosaurus.com/sooperlooper/")