summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-04-24 19:47:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-24 19:49:04 +0200
commit09d2976c86f2cb1841ebe0685164912bfedfeeb5 (patch)
treea09b9595a7df54e61197bfc6fb7a5d22466fc210 /gnu
parentbca1496f7290a0ae9a0186f325f3806b6209e6c3 (diff)
gnu: python-plotly-2.4.1: Patch for Python 3.10 changes.
* gnu/packages/graph.scm (python-plotly-2.4.1)[arguments]: Add phase 'python-compatibility.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graph.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index b719b1be42..1091d3d56e 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -291,8 +291,16 @@ subplots, multiple-axes, polar charts, and bubble charts.")
python-pytz
python-requests
python-six))
- (arguments
- '(#:tests? #f)))) ; The tests are not distributed in the release
+ (arguments
+ (list
+ #:tests? #false ;The tests are not distributed in the release
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'python-compatibility
+ (lambda _
+ (substitute* "plotly/grid_objs/grid_objs.py"
+ (("from collections import MutableSequence")
+ "from collections.abc import MutableSequence")))))))))
(define-public python-louvain
(package