summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-04-21 10:16:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-04-21 13:15:02 +0200
commit2babf3d7d70a52c3543500f09f31c4eaf7a5184e (patch)
treea269f0c37924f11e3421de258271b819da75f3c9 /gnu
parent7c75228c8ba4aaeb8935e9d49db514749cb79f06 (diff)
gnu: Add maffilter.
* gnu/packages/bioinformatics.scm (maffilter): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 511431fb95..c032d107cd 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6046,6 +6046,43 @@ resolution of binding sites through combining the information of both
sequencing tag position and orientation.")
(license license:bsd-3)))
+(define-public maffilter
+ (package
+ (name "maffilter")
+ (version "1.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jydu/maffilter")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "196c16qw82niqqyzi7j1ga1n0zmir73bm26kg04m0i5aq2cpa0ml"))))
+ (build-system cmake-build-system)
+ (arguments (list #:tests? #false)) ;there are none
+ (inputs
+ (list boost
+ bpp-core
+ bpp-phyl
+ bpp-phyl-omics
+ bpp-seq
+ bpp-seq-omics
+ zlib))
+ (home-page "https://jydu.github.io/maffilter/")
+ (synopsis "Multiple alignment format file processor")
+ (description
+ "MafFilter is a program dedicated to the analysis of genome alignments.
+It parses and manipulates @acronym{MAF, multiple alignment format} files as
+well as more simple fasta files. This package can be used to design a
+pipeline as a series of consecutive filters, each performing a dedicated
+analysis. Many of the filters are available, from alignment cleaning to
+phylogeny reconstruction and population genetics analysis. Despite various
+filtering options and format conversion tools, MafFilter can compute a wide
+range of statistics (phylogenetic trees, nucleotide diversity, inferrence of
+selection, etc.).")
+ (license license:gpl3+)))
+
(define-public mafft
(package
(name "mafft")