summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-04-21 22:30:53 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-21 23:01:18 +0200
commit3f7ae420d8a54d4e2ab7f349c40d8930fe9e0771 (patch)
treeb4138ec1fdc50ca7c8aae97707352ca79d0ebcd2 /gnu
parentcbf169608c223cdfb8bbd62f82129d5c674ef0a6 (diff)
gnu: python-cffsubr: Depend on python-afdko@3.6.1.
This removes the dependency of GNOME on Java: gnome -> font-abattis-cantarell -> ... -> openjdk Discussed at <https://lists.gnu.org/archive/html/guix-devel/2022-10/msg00226.html>. * gnu/packages/fontutils.scm (python-cffsubr)[inputs]: Switch to PYTHON-AFDKO-3.6.1.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 3b119a21ec..e7b5dc89a6 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -414,7 +414,11 @@ but also provides many useful font conversion and analysis facilities.
(when tests?
(invoke "pytest" "-vv")))))))
(native-inputs (list python-pytest python-setuptools-scm python-wheel))
- (inputs (list python-afdko))
+
+ ;; Use version 3.6.1, which matches the bundled version and does not
+ ;; depend on Java.
+ (inputs (list python-afdko-3.6.1))
+
(propagated-inputs (list python-fonttools-minimal))
(home-page "https://github.com/adobe-type-tools/cffsubr")
(synopsis "Compact Font Format (CFF) subroutinizer")