summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2021-07-09 12:34:41 +0530
committerArun Isaac <arunisaac@systemreboot.net>2021-08-01 19:20:26 +0530
commit42d9c3b24a0246213b9b9cec5d742bc0be338048 (patch)
tree1b2ee64b79bc21066af4338419b59b6312ab4e3b /gnu
parentedaea8d2ace2745c0d2ecc1429928905815a4439 (diff)
gnu: Add go-lukechampine-com-blake3.
* gnu/packages/golang.scm (go-lukechampine-com-blake3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 972989c84f..8eb93b9456 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8273,3 +8273,30 @@ the External Data Representation (XDR) standard protocol as specified in RFC
friendly sizes. It converts boring ugly numbers to human-friendly strings and
back.")
(license license:expat)))
+
+(define-public go-lukechampine-com-blake3
+ (package
+ (name "go-lukechampine-com-blake3")
+ (version "1.1.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lukechampine/blake3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yxdwp8dpnnq2wbwsxlkbq570i99sc6781y39czjxi9jh9z5nw55"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "lukechampine.com/blake3"))
+ (propagated-inputs
+ `(("go-github-com-klauspost-cpuid" ,go-github-com-klauspost-cpuid)))
+ (home-page "https://pkg.go.dev/lukechampine.com/blake3")
+ (synopsis "Implementation of the BLAKE3 cryptographic hash function")
+ (description "@code{blake3} implements the BLAKE3 cryptographic hash
+function. In addition to the pure-Go implementation, this package also
+contains AVX-512 and AVX2 routines (generated by avo) that greatly increase
+performance for large inputs and outputs.")
+ (license license:expat)))