summaryrefslogtreecommitdiff
path: root/guix/build-system/pyproject.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-08 22:51:17 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-13 15:08:33 +0100
commitae587c2ef041413bc709a555261db752068ea360 (patch)
treebaad8a82afd3433d262cf628de3343b6f1de8151 /guix/build-system/pyproject.scm
parenteee95b5a879b7096dffd533f24107cf8926b621e (diff)
guix: Strip #:use-module lists.
This was obtained by setting up this environment: guix shell -D guix --with-input=guile@3.0.9=guile-next \ --with-commit=guile-next=e2ed33ef0445c867fe56c247054aa67e834861f2 -- make -j5 then adding 'unused-module' to (@@ (guix build compiler) %warnings), building, and checking all the "unused module" warnings and removing those that were definitely unused.
Diffstat (limited to 'guix/build-system/pyproject.scm')
-rw-r--r--guix/build-system/pyproject.scm4
1 files changed, 0 insertions, 4 deletions
diff --git a/guix/build-system/pyproject.scm b/guix/build-system/pyproject.scm
index 8f3b562ca3..44d6650ba9 100644
--- a/guix/build-system/pyproject.scm
+++ b/guix/build-system/pyproject.scm
@@ -22,18 +22,14 @@
#:use-module (guix gexp)
#:use-module (guix store)
#:use-module (guix utils)
- #:use-module (guix memoization)
#:use-module (guix gexp)
#:use-module (guix monads)
#:use-module (guix packages)
- #:use-module (guix derivations)
#:use-module (guix search-paths)
#:use-module (guix build-system)
#:use-module (guix build-system gnu)
#:use-module (guix build-system python)
- #:use-module (ice-9 match)
#:use-module (srfi srfi-1)
- #:use-module (srfi srfi-26)
#:export (%pyproject-build-system-modules
default-python
pyproject-build