summaryrefslogtreecommitdiff
path: root/guix/build-system/pyproject.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-07-23 11:22:03 +0200
committerLars-Dominik Braun <lars@6xq.net>2024-06-30 09:18:38 +0200
commit28af7bc39efc88e6209d6424f809c3b1f54c9818 (patch)
treefe3703372b2b7130c10e3cdc80eb3d2175e21c75 /guix/build-system/pyproject.scm
parentd993654392a56375eb7cdf964728a6970e8579ed (diff)
build-system/pyproject: Use TOML parser.
More reliable than regular expressions. * guix/build-system/pyproject.scm (%pyproject-build-system-modules): Add (guix build toml). (pyproject-build): Add argument #:backend-path. * guix/build/pyproject-build-system.scm (build): Add support for auto-detected and override backend-path. * gnu/packages/python-build.scm (python-tomli)[arguments]: Remove 'add-self-to-path, because it is not necessary any more. (python-poetry-core): Same. (python-hatchling): Same. (python-pdm-backend): Same.
Diffstat (limited to 'guix/build-system/pyproject.scm')
-rw-r--r--guix/build-system/pyproject.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/guix/build-system/pyproject.scm b/guix/build-system/pyproject.scm
index 94b9d79692..585117cbf0 100644
--- a/guix/build-system/pyproject.scm
+++ b/guix/build-system/pyproject.scm
@@ -46,6 +46,7 @@
;; Build-side modules imported by default.
`((guix build pyproject-build-system)
(guix build json)
+ (guix build toml)
,@%python-build-system-modules))
(define (default-python)
@@ -93,6 +94,7 @@
#:key source
(tests? #t)
(configure-flags ''())
+ (backend-path #f)
(build-backend #f)
(test-backend #f)
(test-flags ''())
@@ -116,6 +118,7 @@
#:source #+source
#:configure-flags #$configure-flags
#:system #$system
+ #:backend-path #$backend-path
#:build-backend #$build-backend
#:test-backend #$test-backend
#:test-flags #$test-flags