summaryrefslogtreecommitdiff
path: root/guix/build-system/pyproject.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-11 08:33:02 +0200
committerLars-Dominik Braun <lars@6xq.net>2024-06-30 09:18:32 +0200
commit44a6091ea29b851fbdac061fcff8cd99d5793908 (patch)
tree4eae7726202aca72eac4a74749278281208b0823 /guix/build-system/pyproject.scm
parentab41f5ec1cf559708165e1cd28e15538e6a197d6 (diff)
build-system/pyproject: Use python-sans-pip-wrapper as default-python.
Also adds python-setuptools and python-wheel to relevant packages, either to native-inputs or to propagated inputs if the pkg_resources Python module is loaded at runtime. * guix/build-system/pyproject.scm (default-python): Default to python-sans-pip-wrapper. Change-Id: I2d986c2225114f54459dd6bb360913106e52cdf4
Diffstat (limited to 'guix/build-system/pyproject.scm')
-rw-r--r--guix/build-system/pyproject.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/guix/build-system/pyproject.scm b/guix/build-system/pyproject.scm
index 2a2c3af3f3..94b9d79692 100644
--- a/guix/build-system/pyproject.scm
+++ b/guix/build-system/pyproject.scm
@@ -52,7 +52,12 @@
"Return the default Python package."
;; Lazily resolve the binding to avoid a circular dependency.
(let ((python (resolve-interface '(gnu packages python))))
- (module-ref python 'python-toolchain)))
+ ;; We are using python-sans-pip-wrapper, because it does not contain
+ ;; setuptools. This allows us to skip the dependency on setuptools for
+ ;; packages which don’t need it. And it allows us to more easily swap
+ ;; out setuptools if a different version is required.
+ ;; Using python-toolchain here might cause dependency cycles.
+ (module-ref python 'python-sans-pip-wrapper)))
(define sanity-check.py
(search-auxiliary-file "python/sanity-check.py"))