summaryrefslogtreecommitdiff
path: root/guix/build-system/pyproject.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-07-30 13:36:37 +0200
committerLars-Dominik Braun <lars@6xq.net>2024-06-30 09:18:38 +0200
commite1720e15b2f683a64d3060656fc9a93c600e6b63 (patch)
tree3e3dd8aecb352eb3e9445236fa1a204a46b64cef /guix/build-system/pyproject.scm
parent28af7bc39efc88e6209d6424f809c3b1f54c9818 (diff)
guix: pyproject-build-system: Default configure-flags to empty dictionary.
PEP 517 specifies it should be a dictionary and thus meson-python cannot handle an empty list. Fixes: <https://issues.guix.gnu.org/62781> * guix/build-system/pyproject.scm (lower): Change default of configure-flags. * gnu/packages/build-tools.scm (meson-python)[arguments]: Remove #:build-backend, which was a workaround for this bug. [native-inputs]: Remove python-p~a-build and python-wheel, which are not required when using the default build system. Change-Id: I240ced5c88cf55cbee0d6005d7657bfb6b653b12
Diffstat (limited to 'guix/build-system/pyproject.scm')
-rw-r--r--guix/build-system/pyproject.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build-system/pyproject.scm b/guix/build-system/pyproject.scm
index 585117cbf0..c0e089eac7 100644
--- a/guix/build-system/pyproject.scm
+++ b/guix/build-system/pyproject.scm
@@ -93,7 +93,7 @@
(define* (pyproject-build name inputs
#:key source
(tests? #t)
- (configure-flags ''())
+ (configure-flags ''(@))
(backend-path #f)
(build-backend #f)
(test-backend #f)