summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-03-29 12:52:56 +0200
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 21:29:00 -0500
commit7f94e81a13654cd3c9801ac0c78a485d51669e35 (patch)
treee6576f45a3673a90e12e1fd3bc37c30038d43fa8 /guix/build-system
parentc20736562de91ec994e90678fa3ea5083abb114e (diff)
build-system: python: Add allowed/disallowed keyword arguments.
* gnu/build-system/python.scm (python-build) Add ALLOWED-REFERENCES and DISALLOWED-REFERENCES keywords. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com> Change-Id: I80bfe8e23b8475a8ca277cddd4275f1e757db8c3
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/python.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/guix/build-system/python.scm b/guix/build-system/python.scm
index b987aeef4e..a51c033d01 100644
--- a/guix/build-system/python.scm
+++ b/guix/build-system/python.scm
@@ -179,7 +179,9 @@ pre-defined variants."
(guile #f)
(imported-modules %python-build-system-modules)
(modules '((guix build python-build-system)
- (guix build utils))))
+ (guix build utils)))
+ allowed-references
+ disallowed-references)
"Build SOURCE using PYTHON, and with INPUTS. This assumes that SOURCE
provides a 'setup.py' file as its build system."
(define build
@@ -204,14 +206,15 @@ provides a 'setup.py' file as its build system."
search-paths))
#:inputs %build-inputs)))))
-
(mlet %store-monad ((guile (package->derivation (or guile (default-guile))
system #:graft? #f)))
(gexp->derivation name build
#:system system
#:graft? #f ;consistent with 'gnu-build'
#:target #f
- #:guile-for-build guile)))
+ #:guile-for-build guile
+ #:allowed-references allowed-references
+ #:disallowed-references disallowed-references)))
(define python-build-system
(build-system