summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-02 22:42:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-02 22:42:53 +0200
commitb9212a5455304661d1e969ced5df63aa9b6b761f (patch)
treee2857c8336cc1dbae087ba4717707bc24b4df2dd /guix/build-system
parenta413bc8bd3c2c7d00d8d021a2224a59d26765dad (diff)
parent5f6887e839c10f0c905969d07baca4e03f453e82 (diff)
Merge branch 'core-updates'
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/cmake.scm2
-rw-r--r--guix/build-system/glib-or-gtk.scm2
2 files changed, 4 insertions, 0 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 2e6784251e..1bc1879be5 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -84,6 +84,7 @@
(tests? #t)
(test-target "test")
(parallel-build? #t) (parallel-tests? #f)
+ (validate-runpath? #t)
(patch-shebangs? #t)
(strip-binaries? #t)
(strip-flags ''("--strip-debug"))
@@ -121,6 +122,7 @@ provides a 'CMakeLists.txt' file as its build system."
#:test-target ,test-target
#:parallel-build? ,parallel-build?
#:parallel-tests? ,parallel-tests?
+ #:validate-runpath? ,validate-runpath?
#:patch-shebangs? ,patch-shebangs?
#:strip-binaries? ,strip-binaries?
#:strip-flags ,strip-flags
diff --git a/guix/build-system/glib-or-gtk.scm b/guix/build-system/glib-or-gtk.scm
index 85d01961a5..954c716893 100644
--- a/guix/build-system/glib-or-gtk.scm
+++ b/guix/build-system/glib-or-gtk.scm
@@ -127,6 +127,7 @@
(test-target "check")
(parallel-build? #t)
(parallel-tests? #t)
+ (validate-runpath? #t)
(patch-shebangs? #t)
(strip-binaries? #t)
(strip-flags ''("--strip-debug"))
@@ -175,6 +176,7 @@
#:test-target ,test-target
#:parallel-build? ,parallel-build?
#:parallel-tests? ,parallel-tests?
+ #:validate-runpath? ,validate-runpath?
#:patch-shebangs? ,patch-shebangs?
#:strip-binaries? ,strip-binaries?
#:strip-flags ,strip-flags