summaryrefslogtreecommitdiff
path: root/guix/build/cmake-build-system.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2014-04-27 11:09:07 +0200
committerAndreas Enge <andreas@enge.fr>2014-04-27 11:35:26 +0200
commit06ed59825ecc0dc78d4d16d06c129e2f4879201a (patch)
tree6e0efd0e943bf012d0b1127c9d1bf7fcad96b36c /guix/build/cmake-build-system.scm
parent5d17cf8eb96e7f266c3ec8d9e512389d1875401b (diff)
guix: cmake: Add input and package libraries to the rpath, and adapt package
definitions accordingly. * guix/build/cmake-build-system.scm (configure): Add flags. * gnu/packages/maths.scm (lapack): Drop special code. * gnu/packages/ssh.scm (libssh): Drop special code. * gnu/packages/slim.scm (slim): Drop special code and enable shared library. Co-authored-by: Eric Bavier <bavier@member.fsf.org>
Diffstat (limited to 'guix/build/cmake-build-system.scm')
-rw-r--r--guix/build/cmake-build-system.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/guix/build/cmake-build-system.scm b/guix/build/cmake-build-system.scm
index 75998568bc..144552e8de 100644
--- a/guix/build/cmake-build-system.scm
+++ b/guix/build/cmake-build-system.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -48,6 +49,10 @@
(let ((args `(,srcdir
,(string-append "-DCMAKE_INSTALL_PREFIX=" out)
+ ;; add input libraries to rpath
+ "-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=TRUE"
+ ;; add (other) libraries of the project itself to rpath
+ ,(string-append "-DCMAKE_INSTALL_RPATH=" out "/lib")
,@configure-flags)))
(setenv "CMAKE_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
(setenv "CMAKE_INCLUDE_PATH" (getenv "CPATH"))