summaryrefslogtreecommitdiff
path: root/guix/build/cmake-build-system.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-13 18:02:49 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-13 18:02:49 +0200
commite78fd4ca636a19bc286747f8d91bda22cd8f08fd (patch)
tree540b87f495830e0ccb21bacadbeadc8705d27a94 /guix/build/cmake-build-system.scm
parent6eac909b459301912becb854c112532ee3fd7cc3 (diff)
guix: Make cmake build system aware of usual paths.
* guix/build/cmake-build-system.scm (configure): Set CMAKE_LIBRARY_PATH to LIBRARY_PATH and CMAKE_INCLUDE_PATH to CPATH.
Diffstat (limited to 'guix/build/cmake-build-system.scm')
-rw-r--r--guix/build/cmake-build-system.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/guix/build/cmake-build-system.scm b/guix/build/cmake-build-system.scm
index 877d8110d7..449c609398 100644
--- a/guix/build/cmake-build-system.scm
+++ b/guix/build/cmake-build-system.scm
@@ -38,6 +38,8 @@
(if (file-exists? "CMakeLists.txt")
(let ((args `(,(string-append "-DCMAKE_INSTALL_PREFIX=" out)
,@configure-flags)))
+ (setenv "CMAKE_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
+ (setenv "CMAKE_INCLUDE_PATH" (getenv "CPATH"))
(format #t "running 'cmake' with arguments ~s~%" args)
(zero? (apply system* "cmake" args)))
(error "no CMakeLists.txt found"))))