summaryrefslogtreecommitdiff
path: root/guix/build/python-build-system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-14 16:52:17 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-29 22:59:28 +0100
commita665996f58764a0c6e805016915225f911294989 (patch)
tree0feb3ae24f45bd8e32d592b4e259d09027adbfbd /guix/build/python-build-system.scm
parentdedc8320701b3f5d23ccc213c1c0381e00b33785 (diff)
gnu: python: Set SOURCE_DATE_EPOCH to 1 instead of 0.
* gnu/packages/python.scm (python-2)[arguments]: Set SOURCE_DATE_EPOCH to 1 to match what the daemon does. * guix/build/python-build-system.scm (set-SOURCE-DATE-EPOCH): Likewise.
Diffstat (limited to 'guix/build/python-build-system.scm')
-rw-r--r--guix/build/python-build-system.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 6775cc4396..8025b7fec6 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -140,7 +140,7 @@ installed with setuptools."
"Set the 'SOURCE_DATE_EPOCH' environment variable."
;; Use zero as the timestamp in .pyc files so that builds are deterministic.
;; TODO: Remove it when this variable is set in GNU:%STANDARD-PHASES.
- (setenv "SOURCE_DATE_EPOCH" "0"))
+ (setenv "SOURCE_DATE_EPOCH" "1"))
(define %standard-phases
;; 'configure' and 'build' phases are not needed. Everything is done during