summaryrefslogtreecommitdiff
path: root/guix/build/rakudo-build-system.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:17:42 +0000
committerJosselin Poiret <dev@jpoiret.xyz>2024-03-09 15:57:57 +0100
commitb88f60a77ca1660c70e624690e4c4cb902f5caab (patch)
tree8c0278647f891d1534e4a7f207a40afb77efda1a /guix/build/rakudo-build-system.scm
parentd1d1cdfe60cdb4c51f325f6d3bc877bd69bfd9ba (diff)
gnu: rakudo: Update to 2022.04.
* gnu/packages/perl6.scm (rakudo): Update to 2022.04. [source]: Add snippet to delete bundled 3rdparty directory. [arguments]: Add 'remove-calls-to-git', 'fix-paths' and 'disable-failing-tests' phases. Remove 'patch-source-date' phase. Adjust files in 'patch-more-shebangs' phase and sort them. Remove redundant './' from 'configure' phase. Replace Perl extensions and paths with Raku equivalents in 'install-dist-tool' phase. [native-inputs]: Add nqp-configure. [synopsis, description]: Replace mentions of Perl with Raku. * guix/build/rakudo-build-system.scm (install): Replace Perl extension with Raku extension. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'guix/build/rakudo-build-system.scm')
-rw-r--r--guix/build/rakudo-build-system.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build/rakudo-build-system.scm b/guix/build/rakudo-build-system.scm
index 5cf1cc55bc..642cc570d1 100644
--- a/guix/build/rakudo-build-system.scm
+++ b/guix/build/rakudo-build-system.scm
@@ -59,7 +59,7 @@
#t)
(begin
(let ((inst (string-append (assoc-ref inputs "rakudo")
- "/share/perl6/tools/install-dist.p6")))
+ "/share/perl6/tools/install-dist.raku")))
(setenv "RAKUDO_RERESOLVE_DEPENDENCIES" "0")
(setenv "RAKUDO_MODULE_DEBUG" "1") ; be verbose while building
(invoke inst (string-append "--to=" perl6) "--for=site"))))))