summaryrefslogtreecommitdiff
path: root/guix/build/rakudo-build-system.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:17:52 +0000
committerJosselin Poiret <dev@jpoiret.xyz>2024-03-09 15:57:57 +0100
commitc737f854f705360fde4f22bba4c8b9547b78f64c (patch)
tree238b675000b814a17c97b9d0ae9d05ae3166295f /guix/build/rakudo-build-system.scm
parentb88f60a77ca1660c70e624690e4c4cb902f5caab (diff)
gnu: perl6-tap-harness: Update to 0.3.5.
* gnu/packages/perl6.scm (perl6-tap-harness): Update to 0.3.5. [source]: Update URL. Reindent. [arguments]: Replace obsolete prove6 script with manual Raku invocation in 'check' phase. [home-page]: Update. [synopsis]: Replace mention of Perl with Raku. * gnu/packages/rakudo-build-system.scm (check): Replace obsolete prove6 script with manual Raku invocation. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'guix/build/rakudo-build-system.scm')
-rw-r--r--guix/build/rakudo-build-system.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/guix/build/rakudo-build-system.scm b/guix/build/rakudo-build-system.scm
index 642cc570d1..8f9a3b11d8 100644
--- a/guix/build/rakudo-build-system.scm
+++ b/guix/build/rakudo-build-system.scm
@@ -36,7 +36,11 @@
(define* (check #:key tests? inputs with-prove6? #:allow-other-keys)
(if (and tests? (assoc-ref inputs "perl6-tap-harness"))
;(if (and tests? with-prove6?)
- (invoke "prove6" "-I=lib" "t/")
+ (let ((test-files (find-files "t/" "\\.(rakutest|t|t6)$")))
+ (invoke "raku" "-MTAP" "-e"
+ (string-append
+ "my @tests = <" (string-join test-files " ") ">; "
+ "TAP::Harness.new().run(@tests);")))
(format #t "test suite not run~%"))
#t)