summaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-28 14:22:15 -0400
committerMark H Weaver <mhw@netris.org>2014-08-28 14:22:15 -0400
commitc00a9fbfef75d2fc08485f8158ec331bfa99d5ec (patch)
tree4737817ee787c4ec8222ea13d3cfecb2ac98b673 /guix/build
parent83291101c39c1cd1bf472280c24ad68d94248c2e (diff)
parentdd16424466196616b99c13526537a89aaee27f88 (diff)
Merge branch 'master' into core-updates
Conflicts: gnu/packages/base.scm
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/linux-initrd.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/guix/build/linux-initrd.scm b/guix/build/linux-initrd.scm
index bce289987b..d37da9a6ff 100644
--- a/guix/build/linux-initrd.scm
+++ b/guix/build/linux-initrd.scm
@@ -229,8 +229,11 @@ the following:
• 'any', in which case SPEC can be anything.
"
(define max-trials
- ;; Number of times we retry partition label resolution.
- 7)
+ ;; Number of times we retry partition label resolution, 1 second per
+ ;; trial. Note: somebody reported a delay of 16 seconds (!) before their
+ ;; USB key would be detected by the kernel, so we must wait for at least
+ ;; this long.
+ 20)
(define canonical-title
;; The realm of canonicalization.
@@ -254,6 +257,8 @@ the following:
(if (> count max-trials)
(error "failed to resolve partition label" spec)
(begin
+ (format #t "waiting for partition '~a' to appear...~%"
+ spec)
(sleep 1)
(loop (+ 1 count))))))))
;; TODO: Add support for UUIDs.