summaryrefslogtreecommitdiff
path: root/guix/channels.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /guix/channels.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'guix/channels.scm')
-rw-r--r--guix/channels.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/guix/channels.scm b/guix/channels.scm
index 40cbc4bb3a..d44e7a0a3a 100644
--- a/guix/channels.scm
+++ b/guix/channels.scm
@@ -952,6 +952,10 @@ be used as a profile hook."
(backtrace))))
(mkdir #$output))))
+ (define channels
+ (map (compose string->symbol manifest-entry-name)
+ (manifest-entries manifest)))
+
(gexp->derivation-in-inferior "guix-package-cache" build
profile
@@ -960,8 +964,9 @@ be used as a profile hook."
;; instead of failing.
#:silent-failure? #t
- #:properties '((type . profile-hook)
- (hook . package-cache))
+ #:properties `((type . profile-hook)
+ (hook . package-cache)
+ (channels . ,channels))
#:local-build? #t)))
(define %channel-profile-hooks