summaryrefslogtreecommitdiff
path: root/guix/derivations.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
commita9ebd9efd0d97159acbec848ad5fe06f022c8235 (patch)
tree718f8a04ac525537ed2e297bf38bbedb68f4e8f1 /guix/derivations.scm
parentfd060fd30da53f2b0856f6f451f8fd7b8c760d70 (diff)
store: Remove the `fixed?' parameter from `add-to-store'.
* guix/store.scm (add-to-store): Remove the `fixed?' parameter from the public interface. * gnu/packages/bootstrap.scm, guix-download.in, guix/derivations.scm, guix/packages.scm, tests/derivations.scm: Update all callers accordingly.
Diffstat (limited to 'guix/derivations.scm')
-rw-r--r--guix/derivations.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/derivations.scm b/guix/derivations.scm
index a36a6559b4..6f73534c3c 100644
--- a/guix/derivations.scm
+++ b/guix/derivations.scm
@@ -458,7 +458,7 @@ known in advance, such as a file download."
((input . _)
(let ((path (add-to-store store
(basename input)
- #t #t "sha256" input)))
+ #t "sha256" input)))
(make-derivation-input path '()))))
(delete-duplicates inputs)))
(env-vars (env-vars-with-empty-outputs))
@@ -519,7 +519,7 @@ system, imported, and appears under FINAL-PATH in the resulting store path."
(let* ((files (map (match-lambda
((final-path . file-name)
(list final-path
- (add-to-store store (basename final-path) #t #f
+ (add-to-store store (basename final-path) #f
"sha256" file-name))))
files))
(builder