summaryrefslogtreecommitdiff
path: root/guix/ftp.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-12 23:47:49 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-12 23:47:49 +0200
commit457dd86d66bc1ee1ee13a76d03792396fb69ee34 (patch)
treef652df780af8245b51b0363545f938aa40586950 /guix/ftp.scm
parentfb585745adcd2935b179db1ce847318ec3724c4e (diff)
Add (guix ftp) and companion modules.
* guix/ftp-client.scm, guix/ftp.scm, guix/build/ftp.scm: New files. * Makefile.am (MODULES): Add them. * distro/base.scm (libffi): Use `ftp-fetch'.
Diffstat (limited to 'guix/ftp.scm')
-rw-r--r--guix/ftp.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/guix/ftp.scm b/guix/ftp.scm
new file mode 100644
index 0000000000..79bae6ece6
--- /dev/null
+++ b/guix/ftp.scm
@@ -0,0 +1,49 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <ftp://www.gnu.org/licenses/>.
+
+(define-module (guix ftp)
+ #:use-module (guix derivations)
+ #:use-module (guix utils)
+ #:export (ftp-fetch))
+
+;;; Commentary:
+;;;
+;;; Produce fixed-output derivations with data fetched over FTP.
+;;;
+;;; Code:
+
+(define* (ftp-fetch store url hash-algo hash
+ #:optional name
+ #:key (system (%current-system)))
+ "Return the path of a fixed-output derivation in STORE that fetches URL,
+which is expected to have hash HASH of type HASH-ALGO (a symbol). By
+default, the file name is the base name of URL; optionally, NAME can specify
+a different file name."
+ (define builder
+ `(begin
+ (use-modules (guix build ftp))
+ (ftp-fetch ,url %output)))
+
+ (build-expression->derivation store (or name (basename url)) system
+ builder '()
+ #:hash-algo hash-algo
+ #:hash hash
+ #:modules '((guix ftp-client)
+ (guix build ftp)
+ (guix build utils))))
+;;; ftp.scm ends here