summaryrefslogtreecommitdiff
path: root/guix/import/texlive.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-17 11:34:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:05 +0200
commit9fadbf759c7ae0c4555bf43883f3f0a0d8a4e6a6 (patch)
tree783eb1f894a6c76c82c14254a34badf062ce4643 /guix/import/texlive.scm
parentec97cf15693a0567daa741ecf6d21e6e7ec68134 (diff)
gnu: texlive-bin: Do not install all linked scripts.
* gnu/packages/tex.scm (texlive-scripts): Include only core scripts along with their man pages and their dependencies. Also patch them for use in Guix. (texlive-bin): Simplify package. [inputs]: Remove "texlive-extra-src" and "texlive-scripts" inputs. Remove labels from other inputs. [propagated-inputs]: Add TEXLIVE-SCRIPTS. [arguments]: Use G-expressions. <#:configure-flags>: Add "--disable-linked-scripts". <#:phases>: Remove phases relative to scripts. * guix/profiles.scm (texlive-font-maps): Fetch executables from both TEXLIVE-SCRIPTS and TEXLIVE-BIN. * guix/import/texlive.scm (tlpdb-file): Grab file from TEXLIVE-SCRIPTS instead of TEXLIVE-BIN.
Diffstat (limited to 'guix/import/texlive.scm')
-rw-r--r--guix/import/texlive.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/guix/import/texlive.scm b/guix/import/texlive.scm
index 554258f20d..d4fa8bb674 100644
--- a/guix/import/texlive.scm
+++ b/guix/import/texlive.scm
@@ -153,20 +153,20 @@ When TEXLIVE-ONLY is true, only TeX Live packages are returned."
depends)))
(define (tlpdb-file)
- (define texlive-bin
+ (define texlive-scripts
;; Resolve this variable lazily so that (gnu packages ...) does not end up
;; in the closure of this module.
(module-ref (resolve-interface '(gnu packages tex))
- 'texlive-bin))
+ 'texlive-scripts))
(with-store store
(run-with-store store
(mlet* %store-monad
- ((drv (lower-object texlive-bin))
+ ((drv (lower-object texlive-scripts))
(built (built-derivations (list drv))))
(match (derivation->output-paths drv)
(((names . items) ...)
- (return (string-append (first items)
+ (return (string-append (second items) ;"out"
"/share/tlpkg/texlive.tlpdb"))))))))
(define tlpdb