summaryrefslogtreecommitdiff
path: root/guix/profiles.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 18:02:30 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-03 20:17:09 +0200
commitf2d7bbb537dd3e3fa3b0215549640d2d9c0aeaec (patch)
tree7690676f938c31938dcfcb521fa74fdb53822f07 /guix/profiles.scm
parentfbb909ac7e947ebc8aea2c2efca7df3a78dfc3c4 (diff)
gnu: glibc: Look for locale data in versioned sub-directories.
* gnu/packages/base.scm (glibc)[native-search-paths]: Add 'lib/locale/VERSION' for 'GUIX_LOCPATH'. (glibc-locales, glibc-utf8-locales): Write to a VERSION sub-directory. * guix/profiles.scm (ca-certificate-bundle): Adjust LOCPATH value accordingly.
Diffstat (limited to 'guix/profiles.scm')
-rw-r--r--guix/profiles.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/guix/profiles.scm b/guix/profiles.scm
index 0b417a64de..c56ebb145b 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -573,7 +573,9 @@ MANIFEST. Single-file bundles are required by programs such as Git and Lynx."
;; Some file names in the NSS certificates are UTF-8 encoded so
;; install a UTF-8 locale.
- (setenv "LOCPATH" (string-append #+glibc-utf8-locales "/lib/locale"))
+ (setenv "LOCPATH"
+ (string-append #+glibc-utf8-locales "/lib/locale/"
+ #+(package-version glibc-utf8-locales)))
(setlocale LC_ALL "en_US.UTF-8")
(match (append-map ca-files '#$(manifest-inputs manifest))