summaryrefslogtreecommitdiff
path: root/guix/scripts/hash.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-07-01 23:28:21 +0200
committerLudovic Courtès <ludo@gnu.org>2013-07-01 23:28:21 +0200
commit72626a71a96b02fccb2281713c1fdcd09aa194c4 (patch)
treef24a4f73ee47d6478b5ef3a48ddb16e6403b7275 /guix/scripts/hash.scm
parent82323a80850a205866c83a9399cc76336e30847d (diff)
Move `sha256' to (guix hash).
* guix/utils.scm (sha256): Move to... * guix/hash.scm: ... here. New file. * Makefile.am (MODULES): Add it. * guix/derivations.scm, guix/scripts/download.scm, guix/scripts/hash.scm, guix/scripts/refresh.scm, tests/base32.scm, tests/derivations.scm, tests/store.scm: Use (guix hash).
Diffstat (limited to 'guix/scripts/hash.scm')
-rw-r--r--guix/scripts/hash.scm21
1 files changed, 11 insertions, 10 deletions
diff --git a/guix/scripts/hash.scm b/guix/scripts/hash.scm
index 1b14aaadd0..ca3928b8e3 100644
--- a/guix/scripts/hash.scm
+++ b/guix/scripts/hash.scm
@@ -18,16 +18,17 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (guix scripts hash)
- #:use-module (guix base32)
- #:use-module (guix ui)
- #:use-module (guix utils)
- #:use-module (rnrs io ports)
- #:use-module (rnrs files)
- #:use-module (ice-9 match)
- #:use-module (srfi srfi-1)
- #:use-module (srfi srfi-26)
- #:use-module (srfi srfi-37)
- #:export (guix-hash))
+ #:use-module (guix base32)
+ #:use-module (guix hash)
+ #:use-module (guix ui)
+ #:use-module (guix utils)
+ #:use-module (rnrs io ports)
+ #:use-module (rnrs files)
+ #:use-module (ice-9 match)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-26)
+ #:use-module (srfi srfi-37)
+ #:export (guix-hash))
;;;