summaryrefslogtreecommitdiff
path: root/guix/scripts/import.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-18 15:37:20 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-25 14:34:09 +0200
commitc59cc2383d6620f6ebbed80ce1feecae41a64d69 (patch)
treebaaa9c92cd7b2830a4af0b236ed76044f66f7001 /guix/scripts/import.scm
parent51f95d4e6496d299d4852d7659213fdcd8e131bc (diff)
import: Remove Nix importer.
This importer has suffered from bitrot and no longer works with current Nix and Nixpkgs. See <https://bugs.gnu.org/32339> and <https://bugs.gnu.org/36255>. * guix/import/snix.scm, guix/scripts/import/nix.scm, tests/snix.scm: Remove. * Makefile.am (MODULES, SCM_TESTS): Remove them. * guix/scripts/import.scm (importers): Remove "nix". * build-aux/test-env.in: Remove NIXPKGS variable. * configure.ac: Remove '--with-nixpkgs' option. * doc/guix.texi (Invoking guix import): Remove bit about "guix import nix". * etc/completion/fish/guix.fish: Likewise.
Diffstat (limited to 'guix/scripts/import.scm')
-rw-r--r--guix/scripts/import.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/scripts/import.scm b/guix/scripts/import.scm
index 98554ef79b..bbd9a3b190 100644
--- a/guix/scripts/import.scm
+++ b/guix/scripts/import.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 David Thompson <davet@gnu.org>
;;; Copyright © 2018 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
@@ -76,7 +76,7 @@ rather than \\n."
;;; Entry point.
;;;
-(define importers '("gnu" "nix" "pypi" "cpan" "hackage" "stackage" "elpa" "gem"
+(define importers '("gnu" "pypi" "cpan" "hackage" "stackage" "elpa" "gem"
"go" "cran" "crate" "texlive" "json" "opam"))
(define (resolve-importer name)