summaryrefslogtreecommitdiff
path: root/guix/snix.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-29 21:44:31 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-29 21:44:31 +0100
commit4928e50033615e1d130dd84f131eff4cbc702ccf (patch)
tree320ff9bae85de20b0293119653b07b1197eaaa82 /guix/snix.scm
parent14a3a67364f46b24d7e39d64ac92879c3eb7f8eb (diff)
parent3f5a932eeaa8111b841de64b742b1cc408f2419a (diff)
Merge branch 'master' into core-updates
Conflicts: Makefile.am gnu/packages/base.scm
Diffstat (limited to 'guix/snix.scm')
-rw-r--r--guix/snix.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/guix/snix.scm b/guix/snix.scm
index 3a470b9b8b..0c19fecb28 100644
--- a/guix/snix.scm
+++ b/guix/snix.scm
@@ -277,7 +277,7 @@ ATTRIBUTE is true, only that attribute is considered."
%nix-instantiate "--strict" "--eval-only" "--xml"
;; Pass a dummy `crossSystem' argument so that `buildInputs' and
- ;; `buildNativeInputs' are not coalesced.
+ ;; `nativeBuildInputs' are not coalesced.
;; XXX: This is hacky and has other problems.
;"--arg" "crossSystem" cross-system
@@ -423,12 +423,15 @@ location of DERIVATION."
(build-system gnu-build-system)
;; When doing a native Nixpkgs build, `buildInputs' is empty and
- ;; everything is in `buildNativeInputs'. So we can't distinguish
+ ;; everything is in `nativeBuildInputs'. So we can't distinguish
;; between both, here.
+ ;;
+ ;; Note that `nativeBuildInputs' was renamed from
+ ;; `buildNativeInputs' in Nixpkgs sometime around March 2013.
,@(maybe-inputs 'inputs
- (convert-inputs "buildNativeInputs"))
+ (convert-inputs "nativeBuildInputs"))
,@(maybe-inputs 'propagated-inputs
- (convert-inputs "propagatedBuildNativeInputs"))
+ (convert-inputs "propagatedNativeBuildInputs"))
(home-page ,(and=> (find-attribute-by-name "homepage" meta)
attribute-value))