summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 21:47:39 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-21 21:47:39 -0500
commit9077def8bbd8b7c1b055bcdbe72d30029427432a (patch)
tree1ed90d757a98af618c8582da19afbfd0dd1b7e22 /guix
parentf4a76d6ca2d2811970fc94c9120fc05024648f2b (diff)
build-systems: cmake: Add support for #:allowed-references.
Also actually honor #:disallowed-references when cross-compiling. * guix/build-system/cmake.scm (cmake-build): Add #:allowed-references keyword, and pass it to gexp->derivation. (cmake-cross-build): Likewise. Also pass disallowed-references to gexp->derivation which had apparently been forgotten. Change-Id: I1e9861295359b090bd5407c5f76afddf890e36bf
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system/cmake.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/guix/build-system/cmake.scm b/guix/build-system/cmake.scm
index 2bcc8ac046..0b8a651ee0 100644
--- a/guix/build-system/cmake.scm
+++ b/guix/build-system/cmake.scm
@@ -116,6 +116,7 @@
(imported-modules %cmake-build-system-modules)
(modules '((guix build cmake-build-system)
(guix build utils)))
+ allowed-references
disallowed-references)
"Build SOURCE using CMAKE, and with INPUTS. This assumes that SOURCE
provides a 'CMakeLists.txt' file as its build system."
@@ -158,6 +159,7 @@ provides a 'CMakeLists.txt' file as its build system."
#:target #f
#:graft? #f
#:substitutable? substitutable?
+ #:allowed-references allowed-references
#:disallowed-references disallowed-references
#:guile-for-build guile)))
@@ -193,6 +195,7 @@ provides a 'CMakeLists.txt' file as its build system."
(imported-modules %cmake-build-system-modules)
(modules '((guix build cmake-build-system)
(guix build utils)))
+ allowed-references
disallowed-references)
"Cross-build NAME using CMAKE for TARGET, where TARGET is a GNU triplet and
with INPUTS. This assumes that SOURCE provides a 'CMakeLists.txt' file as its
@@ -250,6 +253,8 @@ build system."
#:target target
#:graft? #f
#:substitutable? substitutable?
+ #:allowed-references allowed-references
+ #:disallowed-references disallowed-references
#:guile-for-build guile)))
(define cmake-build-system