summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-24 23:33:30 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-24 23:33:51 +0100
commitdd6b9a3790b8d545c7254dedeb81630a6fa1d66a (patch)
tree00f95730c2dde207e545a2b892731eec88de8c29 /guix
parent3b9c00208868a75e6b77445fcd33d82536448bb2 (diff)
packages: Mark the `inputs' field of <package> as thunked.
* guix/packages.scm (<package>)[inputs]: Mark as thunked. (package-derivation)[expand-input]: Remove case where the input is a procedure. * tests/packages.scm ("trivial with system-dependent input"): Remove `lambda', and use (%current-system). * gnu/packages/bootstrap.scm (package-from-tarball): Likewise for `inputs'. (%bootstrap-glibc, %bootstrap-gcc): Likewise. * gnu/packages/scheme.scm (mit-scheme): Likewise.
Diffstat (limited to 'guix')
-rw-r--r--guix/packages.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/guix/packages.scm b/guix/packages.scm
index a76e51a5d0..f1cd83c7e4 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -113,7 +113,7 @@ representation."
(default '()) (thunked))
(inputs package-inputs ; input packages or derivations
- (default '()))
+ (default '()) (thunked))
(propagated-inputs package-propagated-inputs ; same, but propagated
(default '()))
(native-inputs package-native-inputs ; native input packages/derivations
@@ -272,15 +272,6 @@ PACKAGE for SYSTEM."
(list name (intern file)))
(((? string? name) (? origin? source))
(list name (package-source-derivation store source system)))
- ((and i ((? string? name) (? procedure? proc) sub-drv ...))
- ;; This form allows PROC to make a SYSTEM-dependent choice.
-
- ;; XXX: Currently PROC must return a .drv, a store path, a local
- ;; file name, or an <origin>. If it were allowed to return a
- ;; package, then `transitive-inputs' and co. would need to be
- ;; adjusted.
- (let ((input (proc system)))
- (expand-input (cons* name input sub-drv))))
(x
(raise (condition (&package-input-error
(package package)