summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-28 01:24:34 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-28 01:24:34 +0200
commite3ce5d709f3ba6a3f3a94a24c20a9cd87e6bd07d (patch)
tree8b680281ba2e3f01d957d76f7918c30ce3b3ba0f /tests
parente1e8874ee82cd9e7e6a8f04bb5144eeb69610b7f (diff)
Add a declarative packaging layer.
* Makefile.am (MODULES): Add `guix/packages.scm' and `distro/base.scm'. (TESTS): Add `tests/packages.scm'. (EXTRA_DIST): New variable. * guix/packages.scm, distro/base.scm, tests/packages.scm: New files. * guix/http.scm (http-fetch): Make `name' an optional argument, to match the expectations of `package-source-derivation'.
Diffstat (limited to 'tests')
-rw-r--r--tests/packages.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/tests/packages.scm b/tests/packages.scm
new file mode 100644
index 0000000000..76f63f3662
--- /dev/null
+++ b/tests/packages.scm
@@ -0,0 +1,51 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+
+(define-module (test-packages)
+ #:use-module (guix store)
+ #:use-module (guix utils)
+ #:use-module (guix derivations)
+ #:use-module (guix packages)
+ #:use-module (distro base)
+ #:use-module (srfi srfi-64))
+
+;; Test the high-level packaging layer.
+
+(define %store
+ (false-if-exception (open-connection)))
+
+(test-begin "packages")
+
+(test-skip (if (not %store) 1 0))
+
+(test-assert "GNU Hello"
+ (and (package? hello)
+ (let* ((drv (package-derivation %store hello))
+ (out (derivation-path->output-path drv)))
+ (and (build-derivations %store (list drv))
+ (file-exists? (string-append out "/bin/hello"))))))
+
+(test-end "packages")
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))
+
+;;; Local Variables:
+;;; eval: (put 'test-assert 'scheme-indent-function 1)
+;;; End: