summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/graph.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index b719b1be42..1091d3d56e 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -291,8 +291,16 @@ subplots, multiple-axes, polar charts, and bubble charts.")
python-pytz
python-requests
python-six))
- (arguments
- '(#:tests? #f)))) ; The tests are not distributed in the release
+ (arguments
+ (list
+ #:tests? #false ;The tests are not distributed in the release
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'python-compatibility
+ (lambda _
+ (substitute* "plotly/grid_objs/grid_objs.py"
+ (("from collections import MutableSequence")
+ "from collections.abc import MutableSequence")))))))))
(define-public python-louvain
(package