summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/photo.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 80fc963363..8df1034487 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -211,18 +211,19 @@ cameras (CRW/CR2, NEF, RAF, DNG, and others).")
(define-public libexif
(package
(name "libexif")
- (version "0.6.22")
+ (version "0.6.24")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/libexif/libexif/releases"
- "/download/libexif-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-release/libexif-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libexif/libexif.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0mhcad5zab7fsn120rd585h8ncwkq904nzzrq8vcd72hzk4g2j2h"))))
+ "0zi5vvb0khlzc6xyfayk6mjx5lgkrj8r7s8lfv4j7wkcgndjga0j"))))
(build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake gettext-minimal libtool))
(home-page "https://libexif.github.io/")
(synopsis "Read and manipulate EXIF data in digital photographs")
(description