summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index aaa9e23982..55bf4bfbeb 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2047,6 +2047,19 @@ about.")
(synopsis "Dune element ordering")
(description "This library represents element ordering in OCaml.")))
+(define-public dune-dyn
+ (package
+ (inherit dune-ordering)
+ (name "dune-dyn")
+ (build-system dune-build-system)
+ (arguments
+ `(#:package "dyn"
+ ;; Tests have a cyclic dependency on stdune
+ #:tests? #f))
+ (propagated-inputs (list ocaml-pp dune-ordering))
+ (synopsis "Dune dynamic types")
+ (description "This library represents dynamic types in OCaml.")))
+
(define-public ocaml-csexp
(package
(name "ocaml-csexp")