summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/irc.scm50
-rw-r--r--gnu/packages/irssi.scm70
3 files changed, 48 insertions, 73 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 8eaf8b7eae..ee732c025f 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -167,7 +167,6 @@ GNU_SYSTEM_MODULES = \
gnu/packages/inklingreader.scm \
gnu/packages/inkscape.scm \
gnu/packages/irc.scm \
- gnu/packages/irssi.scm \
gnu/packages/iso-codes.scm \
gnu/packages/java.scm \
gnu/packages/jemalloc.scm \
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 88fcf21d72..0e29f8a691 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,11 +22,16 @@
#:use-module (guix download)
#:use-module (guix packages)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system gnu)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages glib)
+ #:use-module (gnu packages ncurses)
#:use-module (gnu packages kde)
#:use-module (gnu packages kde-frameworks)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages qt))
+ #:use-module (gnu packages qt)
+ #:use-module (gnu packages tls))
(define-public quassel
(package
@@ -66,3 +72,43 @@ clients can attach to and detach from the central core. It resembles the
popular combination of screen and a text-based IRC client such as WeeChat or
irssi, but graphical.")
(license (list license:gpl2 license:gpl3)))) ;; dual licensed
+
+(define-public irssi
+ (package
+ (name "irssi")
+ (version "0.8.17")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/irssi-import/irssi/"
+ "releases/download/0.8.17/irssi-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "01v82q2pfiimx6lh271kdvgp8hl4pahc3srg04fqzxgdsb5015iw"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (ncurses (assoc-ref inputs "ncurses")))
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--with-ncurses=" ncurses)))))
+ %standard-phases)))
+ (inputs
+ `(("glib" ,glib)
+ ("ncurses" ,ncurses)
+ ("openssl" ,openssl)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
+ (home-page "http://www.irssi.org/")
+ (synopsis "Terminal-based IRC client")
+ (description
+ "Irssi is a terminal based IRC client for UNIX systems. It also supports
+SILC and ICB protocols via plugins.")
+ (license license:gpl2+)))
diff --git a/gnu/packages/irssi.scm b/gnu/packages/irssi.scm
deleted file mode 100644
index e5c72186e2..0000000000
--- a/gnu/packages/irssi.scm
+++ /dev/null
@@ -1,70 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages irssi)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages glib)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages tls))
-
-(define-public irssi
- (package
- (name "irssi")
- (version "0.8.17")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/irssi-import/irssi/"
- "releases/download/0.8.17/irssi-"
- version ".tar.bz2"))
- (sha256
- (base32
- "01v82q2pfiimx6lh271kdvgp8hl4pahc3srg04fqzxgdsb5015iw"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (alist-replace
- 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (ncurses (assoc-ref inputs "ncurses")))
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- (string-append "--with-ncurses=" ncurses)))))
- %standard-phases)))
- (inputs
- `(("glib" ,glib)
- ("ncurses" ,ncurses)
- ("openssl" ,openssl)))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("perl" ,perl)))
- (home-page "http://www.irssi.org/")
- (synopsis "Terminal-based IRC client")
- (description
- "Irssi is a terminal based IRC client for UNIX systems. It also supports
-SILC and ICB protocols via plugins.")
- (license license:gpl2+)))