summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/version-control.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index af237ab4ee..ba2f1d6fad 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -911,8 +911,10 @@ other git-like projects such as @code{libgit2}.")
'()))
#:phases
(modify-phases %standard-phases
- ,@(if (target-arm32?)
+ ,@(if (or (target-arm32?) (target-hurd?))
;; Some tests are flaky on armhf.
+ ;; On GNU/Hurd, the 'diff/workdir' test in libgit2 1.7.1 fails
+ ;; while comparing st.st_size to zero.
'((add-before 'check 'pre-check
(lambda _
(setenv "GITTEST_FLAKY_STAT" "true"))))