summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/game-development.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 90205a89ab..b319f2fef3 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -2444,7 +2444,14 @@ computer games, 3D authoring tools and simulation tools.")
(commit (string-append "Chipmunk-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qmkn01g06p3rnhmbyffmjns6wj5vhgf9cscigk3wzxcpwv1hyxb"))))
+ (base32 "1qmkn01g06p3rnhmbyffmjns6wj5vhgf9cscigk3wzxcpwv1hyxb"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(begin
+ ;; This is fixed in the upstream repository but the fix
+ ;; has not been released.
+ (substitute* "src/cpHastySpace.c"
+ (("#include <sys/sysctl.h>") ""))))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no test