summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 9aab17d10e..3b69c8fb36 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -60,6 +60,28 @@
shell-like commands.")
(license license:expat)))
+(define-public go-github-com-armon-go-radix
+ (package
+ (name "go-github-com-armon-go-radix")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/armon/go-radix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1m1k0jz9gjfrk4m7hjm7p03qmviamfgxwm2ghakqxw3hdds8v503"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/armon/go-radix"))
+ (home-page "https://github.com/armon/go-radix")
+ (synopsis "Go implementation of Radix trees")
+ (description "This package provides a single @code{Tree} implementation,
+optimized for sparse nodes of
+@url{http://en.wikipedia.org/wiki/Radix_tree,radix tree}.")
+ (license license:expat)))
+
(define-public go-github-com-djherbis-atime
(package
(name "go-github-com-djherbis-atime")