summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm10
1 files changed, 3 insertions, 7 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0128d6372b..ce799ae33b 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4922,7 +4922,8 @@ fight against their plot and save his fellow rabbits from slavery.")
("python-2" ,python-2)))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags '("config=release" "verbose=1" "-C" "build/workspaces/gcc")
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'delete-bundles
(lambda _
@@ -4949,17 +4950,12 @@ fight against their plot and save his fellow rabbits from slavery.")
(zero? (system* "./update-workspaces.sh"
(string-append "--libdir=" lib)
(string-append "--datadir=" data)
- "--minimal-flags"
;; TODO: "--with-system-nvtt"
"--with-system-mozjs38"))))))
- (add-before 'build 'chdir
- (lambda _
- (chdir "build/workspaces/gcc")
- #t))
(delete 'check)
(replace 'install
(lambda* (#:key inputs outputs #:allow-other-keys)
- (chdir "../../../binaries")
+ (chdir "binaries")
(let* ((out (assoc-ref outputs "out"))
(bin (string-append out "/bin"))
(lib (string-append out "/lib"))