summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am10
-rw-r--r--etc/git/gitconfig16
2 files changed, 26 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7fe18c9f6b..4a9124e0c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -14,6 +14,7 @@
# Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
# Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
# Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+# Copyright © 2020, 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
# Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
# Copyright © 2021 Andrew Tropin <andrew@trop.in>
#
@@ -1112,6 +1113,15 @@ cuirass-jobs: $(GOBJECTS)
.PHONY: clean-go make-go as-derivation authenticate
.PHONY: update-guix-package update-NEWS cuirass-jobs release
+# Git auto-configuration.
+.git/hooks/pre-push: etc/git/pre-push
+ cp etc/git/pre-push .git/hooks/pre-push
+
+.git/config: etc/git/gitconfig
+ git config include.path ../etc/git/gitconfig
+
+nodist_noinst_DATA = .git/hooks/pre-push .git/config
+
# Downloading up-to-date PO files.
WEBLATE_REPO = https://framagit.org/tyreunom/guix-translations
diff --git a/etc/git/gitconfig b/etc/git/gitconfig
index c9ebdc8fa8..831fbce6e7 100644
--- a/etc/git/gitconfig
+++ b/etc/git/gitconfig
@@ -1,5 +1,21 @@
+[commit]
+ gpgsign = true
+
[diff "scheme"]
xfuncname = "^(\\(define.*)$"
[diff "texinfo"]
xfuncname = "^@node[[:space:]]+([^,]+).*$"
+
+[format]
+ forceinbodyfrom = true # help preserve commit authorship
+ thread = shallow
+ useAutoBase = true
+
+[pull]
+ rebase = true
+
+[sendemail]
+ to = guix-patches@gnu.org
+ headerCmd = etc/teams.scm cc-members-header-cmd
+ thread = no