summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioconductor.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9358e75aba..f6946b72c8 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -37,10 +37,12 @@
#:use-module (guix git-download)
#:use-module (guix build-system r)
#:use-module (gnu packages)
+ #:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages bioinformatics)
#:use-module (gnu packages boost)
+ #:use-module (gnu packages chemistry)
#:use-module (gnu packages cran)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
@@ -18852,6 +18854,47 @@ coordinate plots, volcano plots, and litre plots. It includes examples for
visualizing RNA-sequencing datasets and differentially expressed genes.")
(license license:gpl3)))
+(define-public r-chemmineob
+ (package
+ (name "r-chemmineob")
+ (version "1.38.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "ChemmineOB" version))
+ (sha256
+ (base32 "0l44d6l078k1w5nf7i4sarah1zn30zqjmcj9qpy4hhg97dfy45ci"))))
+ (properties `((upstream-name . "ChemmineOB")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-makefile
+ (lambda _
+ (substitute* "src/Makevars.in"
+ (("/usr/include/openbabel3")
+ (string-append #$(this-package-input "openbabel")
+ "/include/openbabel3"))
+ (("/usr/include/eigen3")
+ (string-append #$(this-package-input "eigen")
+ "/include/eigen3"))))))))
+ (inputs (list eigen openbabel))
+ (propagated-inputs (list r-bh r-biocgenerics r-rcpp r-zlibbioc))
+ (native-inputs (list pkg-config r-knitr))
+ (home-page "https://github.com/girke-lab/ChemmineOB")
+ (synopsis "R interface to a subset of OpenBabel functionalities")
+ (description
+ "@code{ChemmineOB} provides an R interface to a subset of cheminformatics
+functionalities implemented by the @code{OpelBabel} C++ project.
+@code{OpenBabel} is an open source cheminformatics toolbox that includes
+utilities for structure format interconversions, descriptor calculations,
+compound similarity searching and more. @code{ChemineOB} aims to make a subset
+of these utilities available from within R. For non-developers,
+@code{ChemineOB} is primarily intended to be used from @code{ChemmineR} as an
+add-on package rather than used directly.")
+ (license license:asl2.0)))
+
(define-public r-chemminer
(package
(name "r-chemminer")